DataCopy - Назначение программы

Программа предназначена для облегчения рутины - копирования измененных или отсутствующих файлов и папок из папок источников в папки-приемники, в том числе - и сетевых. При желании, по окончании копирования данных, программа может запустить указанное пользователем приложение.

Помимо этого, при использовании "продвинутых" настроек можно:

- копировать только новые файлы
- удалять файлы, отсутствующие в файле - источнике
- провести ПОЛНУЮ синхронизацию 2 папок (в случае совпадения файлов в качестве эталона берется папка источник)
- запустить задание в определенное время
- переносить файлы из папки - источника в папку-приемник


DataCopy - Описание ini файла.

DataCopy.ini - Структура и описание

Файл DataCopy.ini содержит различные параметры для нормального функционирования программы. В принципе, Вам не обязательно в него заглядывать - программа сама создает и обновляет параметры, однако... Я человек достаточно дотошный, люблю, чтобы были известны все настройки программы. Посему -

[Main]
DataFullPath=C:\Program Files\Borland\Delphi7\Projects\DataCopy\Data
DefFileNameFullPath=C:\Program Files\Borland\Delphi7\Projects\DataCopy\Data\WatchDef.wth
DefLogNameFullPath=C:\Program Files\Borland\Delphi7\Projects\DataCopy\WatchLog.Log
MinimizeOnStart=1
LogLevel=1

Что означают эти параметры?

DataFullPath - параметр задает полный путь к каталогу данных программы
DefFileNameFullPath - параметр определяет полный путь и имя файла заданий
DefLogNameFullPath - параметр задает полный путь и имя лог-файла
MinimizeOnStart - этот параметр позволяет минимизировать программу в иконку при старте (1- минимизировать при старте, 0 запускать в развернутом виде)
LogLevel - этот параметр позволяет задавать детализацию Log файла. 1 - минимальная детализация, 2 более детально ... 9- очень подробно. Пока реализован только 1 уровень логов


DataCopy - Основное окно

DataCopy

Запуск программы

При запуске программы Вы увидите следующее:

При запуске появляется окно - приветствие, которое исчезает через 2 секунды.

Итак, у нас есть:
- меню программы
- кнопки, дублирующие основные пункты меню
- список существующих заданий
- окошко для сообщений программы
- статусная строка, где отображается процесс синхронизации

Давайте разбираться со всем этим хозяйством.

Меню

Меню содержит следующие пункты:

File
Watch
Settings
Help

File

Здесь всего 2 пункта:

Load Watches - загрузить файл с заданиями который находится в месте, отличном от указанного в ini файле
Exit - завершить работу программы

Watch

Этот пункт отвечает за задания синхронизации:

Add Watch - отвечает за добавление в список нового задания
Edit Watch - позволяет отредактировать выбранное в списке задание
Delete Watch - удаляет выбранное задание
Check Now - вне зависимости от типа выбранного задания запускает его на немедленное выполнение

Settings

Настройки программы - пока только один пункт:

Minimize on Start - позволяет при запуске программы минимизировать ее в трей

Help

Пункт Помощь

Send your bug reports - отправить электронной почтой отчет об ошибках программы
Send your comments - отправить электронной почтой комментарии к программе
About... - показывает окошко с информацией о программе, ее веб-сайте

Кнопки

Здесь все просто - перечислю слева направо

Создать новое задание
Отредактировать задание
Удалить задание
Запустить на выполнение задание
Завершить программу

Список заданий

Список заданий представляет собой набор строк, содержащий следующую информацию

Статус задания - отображается пиктограммой, так же указывается ID задания
Папка-источник - откуда будут копироваться папки и файлы
Папка-приемник - куда будут копироваться папки и файлы

Log events

В этом списке отображаются последние несколько событий программы. Одновременно происходит запись событий в log файл, указанный в ini файле


DataCopy - Создание/редактирование задания

Создание задания

При выборе пункта меню Add Watch Вы увидите следующее:

Окно содержит две закладки

Main - закладка для определения папки- источника данных, папки - приемника данных, маски файлов, типа отчета
Advanced - закладка, на которой настраиваются различные моменты синхронизации

Закладка Main

Идем сверху вниз

Source folder - с помощью кнопки с раскрытой папкой выбираем папку- источник данных

Destination folder - папка - приемник данных
File type - в этом поле Вы можете задать маску поиска файлов. Причем через запятую, двоеточие или точку с запятой можно задать несколько масок например *.exe, *.bat, da*.Dat
Wide Log - если установить галочку - в Log - файл будет записываться более подробная информация о действиях программы
Copy with root folder - если установлена галочка - в папку - приемник будет скопирована и папка источник
Поясняю. К примеру папка источник - 1. Если галочки нет - в папке 2 окажется содержимое папки 1, если есть галочка - в папке 2 окажется папка 1 с содержимым

Закладка Advanced

У нас есть две области Syncro type и Syncronize files

Syncro type

Что мы имеем сдесь:

Область Run Syncro

Предназначена для определения способа запуска задания

Stop - задание остановлено, его нельзя запустить выполняться даже с помощью команды Check Now
On Start - задание запускается при старте программы
Manual - задание выполняется с помощью команды Check Now
Timer - задание выполняется по таймеру (см.Syncronize files )

Область Options Syncro

Bidirect Sync - синхронизация происходит по следующему алгоритму - вначале синхронизация происходит как обычно, а затем папка источник меняется ролями с папкой - приемником (во закрутил)
Delete Epsend files- удалять в папке-приемнике отсутствующие в папке - источнике файлы

Область Files Syncro

Здесь Вы определяете - файлы из папки-источника будут прерноситься или копироваться в папку - приемник

Область Tune Syncro Syncro All - производится синхронизация всего и вся (в пределах задания) по следующему алгоритму
- если размеры файлов не совпадают
- если файл в папке - источнике новее
- если в папке - приемнике нет такого файла
то копировать файл
Update only old Files - сравнивать существующие файлы, если дата создания файла в папке - источнике новее - копировать файл
Copy only epsend files - если в папке приемнике нет такого файла - копировать его

Syncronize Files

Эта часть закладки становиться доступной в том слкчае, если в разделе Run Syncro выбрано Timer. В результате мы можем определить - когда выполнять задание

10 minuts - 1 раз в 10 минут
1 Hour - 1 раз в час
1 Day- 1 раз в день
1 Week - 1 раз в неделю
10 Days - 1 раз в 10 дней
1 Month - 1 раз в месяц
On Time: - если выбран этот пункт - можно установить выполнение задания точно в указанное время

Run after Syncro

В этом разделе мы можем указать какой файл по окончании задания запустить и с какими параметрами командной строки. К примеру можно сархивировать скопированные данные.


 Сайт программы DataCopy


 Автор - Алексей Стахнов


DataCopy описание

 DataCopy.ini - описание файла
Главное окно программы
Создание/редактирование задания